Classic Forum Home Page

Community Server

Group for Content about my AlexCrome.CS addon package for Community Server 2008

Classic Forum Home Page

Rate This
  • Comments 14

image Whilst I do prefer the Hawaii forum view to the more typical forum views from past versions of CS, it does take a bit of getting used to, and I don’t dare to impost it on the users on my personal CS site (Nintendo Wiikly) for fear of a revolt – one lost user for me would be a loss of about 10% of my active user base :( – I decided to return to the old style of forum view.

To do this, I copied the grouplist.aspx page from the old calypso theme, and updated it to work with CS2008 (and then again for CS2008.5).  You can see the page I’m using (for CS2008.5) in the forums.

There are a few other niceties of this page over the default – it displays the group description when viewing the forum list for a specific forum group, and the description and name are editible inline.  The page also allows you to personalise the list of forums & groups you see so you see more of the content which is relevant to you.

You can download the files to change your forum homepage below

Instructions on installing the updated page are included in the readme.txt file.

If you find any errors in the markup, or something that was left out of the package, add a comment and I’ll fix the error for others who come to use the page.

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment
  • Post
  • Thanks Alex for your post....

  • Great post Alex. Unless I did something wrong (using 2008.5) All my "Most Active Users" show counts of "0" posts.

    I'm going to try to see if I can figure out how to fix this. In the mean time I thought I'd just let you know, or perhaps it's only my install that is having this problem. I'm not sure.

  • That sounds like it's nothing to do with the clasic forum post.

    Active users are based on the number of posts made within the last 24 hours. So if no one's posted in the last 24 hours, they'll show 0.

    Values are cached for a while so may take a bit to update.

  • Hi Alex, yes I considered the caching issue. I was looking through the documentation and all the code appears to be right. I'm stumped for the moment as to why those values are showing 0's. For what it's worth I'm also getting blank values at the bottom of your page where the most popular thread, and post subjects are.

    I don't suspect it has anything to do with your page at this point... but I'm definitely puzzled. If I click on any of the users to link to their profile... their post count is accurately reflected there... so it seems the counts ARE working. I'll keep at it.

    Thanks for your efforts and your prompt response!

  • The number is NOT post count. It is hte number of posts made IN THE LAST 24 HOURS or so.

  • Great stuff Alex! I like it, I just kept the new "Recent/Unanswered/Unread/Your Discussion" top on the page...

  • Hi Alex,

    Can you help me, please. I'm using CS2008.5 with ForumClassicView of you. And my forum have subforum, and I must fix threadlist.aspx for to L&G theme.

    Can you suggesion for me edit this file?

    P/S: if have no subforum then we only edit grouplist.aspx.

    Thanks

    slnavn2000

  • slnavn,

    Compare the threadlist.aspx file included in the download with the out of the box hawaii threadlist.aspx page in CS2008.5 and make the same changes I made to the hawaii filteredthreadlist.aspx page to the leanandgreen page.

  • what happened to the download link?
  • Sorry about that Peter - just moved my site and need to fix a few issues with the move. The links are updated now. If they still don't work for you, you can find the files in the Media Gallery.
  • Alex, It looks like both the 2008 and 2008.5 links to the same download. When I tried to load it with the instructions provided in the text file it's showing: Sorry, there was a problem with your last request! Either the site is offline or an unhandled error occurred. We apologize and have logged the error. Please try your request again or if you know who your site administrator is let them know too.
  • nguyenpv1980 - I've fixed the link. Make sure to download the right file for your site and see if that works.
  • Hi Alex

    I really need to use this layout but i am using a different theme. Can you please point me to the right areas how to merge/achieve the same result?

    Thanks in advance

  • Are you using one of Andrew Belon's http://www.andrewbelon.com/ themes ?  If so they've based on the Hawaii theme so you can use the provided files - just copy to your custom theme instead of the hawaii theme.

    If not, download the Hawaii version of hte page, and have a look at the markup there for how to do it.

Page 1 of 1 (14 items)
Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment
  • Post